星期一, 3月 29, 2010

[轉貼]DHCP 協定

來源網址:http://www.pcnet.idv.tw/pcnet/network/network_ip_dhcp.htm

經過了前面的學習,相信您不再認為設定與管理 TCP/IP 網路是件輕鬆的事情。要成功的將您的網路用 TCP/IP 連接起來,您就得為每台電腦設定 IP、mask、gateway、等等繁瑣的事情。要是您想管理好一個比較大的網路﹐或是電腦節點經常改變(如手提電腦或撥接)﹐這樣的工作可以說是非常令人討厭的﹐而且出錯的機會也比較多。要是,萬一日後要進行 IP 重新規劃﹐其工作量也是相當驚人的。
面對這些情形﹐DHCP 可以說您的菩薩了﹕它不但救苦救難﹐而且神通廣大。
什麼是 DHCP?
DHCP 是 Dynamic Host Configuration Protocol 之縮寫﹐它的前身是 BOOTP。BOOTP 原本是用於無磁碟主機連接的網路上面的﹕網路主機使用 BOOT ROM 而不是磁碟起動並連接上網路﹐BOOTP 則可以自動地為那些主機設定 TCP/IP 環境。但 BOOTP 有一個缺點:您在設定前須事先獲得客戶端的硬體位址,而且,與 IP 的對應是靜態的。換而言之,BOOTP 非常缺乏 "動態性" ,若在有限的 IP 資源環境中,BOOTP 的一對一對應會造成非常可觀的浪費。
DHCP 可以說是 BOOTP 的增強版本﹐它分為兩個部份﹕一個是伺服器端﹐而另一個是客戶端。所有的 IP 網路設定資料都由 DHCP 伺服器集中管理﹐並負責處理客戶端的 DHCP 要求﹔而客戶端則會使用從伺服器分配下來的IP環境資料。比較起 BOOTP ,DHCP 透過 "租約" 的概念,有效且動態的分配客戶端的 TCP/IP 設定,而且,作為兼容考量,DHCP 也完全照顧了 BOOTP Client 的需求。
DHCP 的分配形式
首先﹐必須至少有一台 DHCP 工作在網路上面﹐它會監聽網路的 DHCP 請求﹐並與客戶端搓商 TCP/IP 的設定環境。它提供兩種 IP 定位方式﹕

Automatic Allocation
自動分配﹐其情形是﹕一旦 DHCP 客戶端第一次成功的從 DHCP 伺服器端租用到 IP 位址之後﹐就永遠使用這個位址。
Dynamic Allocation
動態分配﹐當 DHCP 第一次從 HDCP 伺服器端租用到 IP 位址之後﹐並非永久的使用該位址﹐只要租約到期﹐客戶端就得釋放(release)這個 IP 位址﹐以給其它工作站使用。當然﹐客戶端可以比其它主機更優先的延續(renew)租約﹐或是租用其它的 IP 位址。

動態分配顯然比自動分配更加靈活﹐尤其是當您的實際 IP 位址不足的時候﹐例如﹕您是一家 ISP ﹐只能提供 200 個IP位址用來給撥接客戶﹐但並不意味著您的客戶最多只能有 200 個。因為要知道﹐您的客戶們不可能全部同一時間上網的﹐除了他們各自的行為習慣的不同﹐也有可能是電話線路的限制。這樣﹐您就可以將這 200 個位址﹐輪流的租用給撥接上來的客戶使用了。這也是為什麼當您查看 IP 位址的時候﹐會因每次撥接而不同的原因了(除非您申請的是一個固定 IP ﹐通常的 ISP 都可以滿足這樣的要求﹐這或許要另外收費)。當然﹐ISP 不一定使用 DHCP 來分配位址﹐但這個概念和使用 IP Pool 的原理是一樣的。
DHCP 除了能動態的設定 IP 位址之外﹐還可以將一些 IP 保留下來給一些特殊用途的機器使用﹐它可以按照硬體位址來固定的分配 IP 位址﹐這樣可以給您更大的設計空間。同時﹐DHCP 還可以幫客戶端指定 router﹑netmask﹑DNS Server﹑WINS Server﹑等等項目﹐您在客戶端上面﹐除了將 DHCP 選項打勾之外﹐幾乎無需做任何的 IP 環境設定。
DHCP 的工作原理
視乎客戶端是否第一次登錄網路﹐DHCP 的工作形式會有所不同。
第一次登錄的時候﹕

  1. 尋找 Server。當 DHCP 客戶端第一次登錄網路的時候﹐也就是客戶發現本機上沒有任何 IP 資料設定﹐它會向網路發出一個 DHCPDISCOVER 封包。因為客戶端還不知道自己屬於哪一個網路﹐所以封包的來源位址會為 0.0.0.0 ﹐而目的位址則為 255.255.255.255 ﹐然後再附上 Dhcpdiscover 的信息﹐向網路進行廣播。
    在 Windows 的預設情形下,Dhcpdiscover 的等待時間預設為 1 秒﹐也就是當客戶端將第一個 Dhcpdiscover 封包送出去之後﹐在 1 秒之內沒有得到回應的話﹐就會進行第二次 Dhcpdiscover 廣播。若一直得不到回應的情況下﹐客戶端一共會有四次 Dhcpdiscover 廣播(包括第一次在內)﹐除了第一次會等待 1 秒之外﹐其余三次的等待時間分別是 9﹑13﹑16 秒。如果都沒有得到 DHCP 伺服器的回應﹐客戶端則會顯示錯誤信息﹐宣告 Dhcpdiscover 的失敗。之後﹐基於使用者的選擇﹐系統會繼續在 5 分鐘之後再重複一次 Dhcpdiscover 的過程。
  2. 提供 IP 租用位址。當 DHCP 伺服器監聽到客戶端發出的 Dhcpdiscover 廣播後﹐它會從那些還沒有租出的位址範圍內﹐選擇最前面的的空置 IP ,連同其它 TCP/IP 設定,回應給客戶端一個 DHCPOFFER 封包。
    由於客戶端在開始的時候還沒有 IP 位址﹐所以在其 Dhcpdiscover 封包內會帶有其 MAC 位址信息﹐並且有一個 XID 編號來辨別該封包﹐DHCP 伺服器回應的 Dhcpoffer 封包則會根據這些資料傳遞給要求租約的客戶。根據伺服器端的設定﹐Dhcpoffer 封包會包含一個租約期限的信息。
  3. 接受 IP 租約。如果客戶端收到網路上多台 DHCP 伺服器的回應﹐只會挑選其中一個 Dhcpoffer 而已(通常是最先抵達的那個)﹐並且會向網路發送一個Dhcprequest廣播封包﹐告訴所有 DHCP 伺服器它將指定接受哪一台伺服器提供的 IP 位址。
    同時﹐客戶端還會向網路發送一個 ARP 封包﹐查詢網路上面有沒有其它機器使用該 IP 位址﹔如果發現該 IP 已經被佔用﹐客戶端則會送出一個 DHCPDECLINE 封包給 DHCP 伺服器﹐拒絕接受其 Dhcpoffer ﹐並重新發送 Dhcpdiscover 信息。
    事實上﹐並不是所有 DHCP 客戶端都會無條件接受 DHCP 伺服器的 offer ﹐尤其這些主機安裝有其它 TCP/IP 相關的客戶軟體。客戶端也可以用 Dhcprequest 向伺服器提出 DHCP 選擇﹐而這些選擇會以不同的號碼填寫在 DHCP Option Field 裡面﹕



    號碼代表意思
    01Sub-net Mask
    03Router Address
    06DNS Server Address
    0FDomain Name
    2CWINS/NBNS Server Address
    2EWINS/NBT Node Type
    2FNetBIOS Scope ID

    換一句話說﹐在 DHCP 伺服器上面的設定﹐未必是客戶端全都接受﹐客戶端可以保留自己的一些 TCP/IP 設定。而主動權永遠在客戶端這邊。
  4. 租約確認。當 DHCP 伺服器接收到客戶端的 Dhcprequest 之後﹐會向客戶端發出一個 DHCPACK 回應﹐以確認 IP 租約的正式生效﹐也就結束了一個完整的 DHCP 工作過程。

如上的工作流程如下圖:
DHCP 發放流程
第一次登錄之後﹕
一旦 DHCP 客戶端成功地從伺服器哪裡取得 DHCP 租約之後﹐除非其租約已經失效並且 IP 位址也重新設定回 0.0.0.0 ﹐否則就無需再發送 Dhcpdiscover 信息了﹐而會直接使用已經租用到的 IP 位址向之前之 DHCP 伺服器發出 Dhcprequest 信息﹐DHCP 伺服器會儘量讓客戶端使用原來的 IP 位址﹐如果沒問題的話﹐直接回應 Dhcpack 來確認則可。如果該位址已經失效或已經被其它機器使用了﹐伺服器則會回應一個 DHCPNACK 封包給客戶端﹐要求其從新執行 Dhcpdiscover。
至於 IP 的租約期限卻是非常考究的﹐並非如我們租房子那樣簡單﹐ 以 NT 為例子﹕DHCP 工作站除了在開機的時候發出 dhcprequest 請求之外﹐在租約期限一半的時候也會發出 dhcprequest ﹐如果此時得不到 DHCP 伺服器的確認的話﹐工作站還可以繼續使用該 IP ﹔然後在剩下的租約期限的再一半的時候(即租約的75%)﹐還得不到確認的話﹐那麼工作站就不能擁有這個 IP 了。至於為什麼不是到租約期限完全結束才放棄 IP 呢﹖﹐對不起﹐小弟也是不學無術之人﹐沒有去深究了﹐只知道要回答 MCSE 題目的時候﹐您一定要記得 NT 是這麼工作的就是了。
要是您想退租,可以隨時送出 DHCPLEREASE 命令解約﹐就算您的租約在前一秒鐘才獲得的。

跨網路的 DHCP 運作
從前面描述的過程中,我們不難發現:DHCDISCOVER 是以廣播方式進行的,其情形只能在同一網路之內進行﹐因為 router 是不會將廣播傳送出去的。但如果 DHCP 伺服器安設在其它的網路上面呢﹖由於 DHCP 客戶端還沒有 IP 環境設定﹐所以也不知道 Router 位址﹐而且有些 Router 也不會將 DHCP 廣播封包傳遞出去﹐因此這情形下 DHCPDISCOVER 是永遠沒辦法抵達 DHCP 伺服器那端的,當然也不會發生 OFFER 及其他動作了。要解決這個問題,我們可以用 DHCP Agent (或 DHCP Proxy )主機來接管客戶的 DHCP 請求﹐然後將此請求傳遞給真正的 DHCP 伺服器﹐然後將伺服器的回覆傳給客戶。這裡﹐Proxy 主機必須自己具有路由能力,且能將雙方的封包互傳對方。
若不使用 Proxy,您也可以在每一個網路之中安裝 DHCP 伺服器﹐但這樣的話﹐一來設備成本會增加﹐而且﹐管理上面也比較分散。當然囉﹐如果在一個十分大型的網路中﹐這樣的均衡式架構還是可取的。端視您的實際情況而定了。
DHCP 封包格式
081624
31
OPHTYPEHLENHOPS
TRANSACTION ID
SECONDSFLAGS
ciaddr
yiaddr
siaddr
giaddr
chaddr(16 bytes)
sname(64 bytes)
file(128 bytes)
Options(312 bytes)


以下為各欄位的簡要說明:

OP
若是 client 送給 server 的封包,設為 1 ,反向為 2 。
HTYPE
硬體類別,Ethernet 為 1 。
HLEN
硬體位址長度, Ethernet 為 6 。
HOPS
若封包需經過 router 傳送,每站加 1 ,若在同一網內,為 0 。
TRANSACTION ID
DHCPREQUEST 時產生的數值,以作 DHCPREPLY 時的依據。
SECONDS
Client 端啟動時間(秒)。
FLAGS
從 0 到 15 共 16 bits ,最左一 bit 為 1 時表示 server 將以廣播方式傳送封包給 client ,其餘尚未使用。
ciaddr
要是 client 端想繼續使用之前取得之 IP 位址,則列於這裡。
yiaddr
從 server 送回 client 之 DHCPOFFER 與 DHCPACK 封包中,此欄填寫分配給 client 的 IP 位址。
siaddr
若 client 需要透過網路開機,從 server 送出之 DHCPOFFER、DHCPACK、DHCPNACK 封包中,此欄填寫開機程式碼所在 server 之位址。
giaddr
若需跨網域進行 DHCP 發放,此欄為 relay agent 的位址,否則為 0 。
chaddr
Client 之硬體位址。
sname
Server 之名稱字串,以 0x00 結尾。
file
若 client 需要透過網路開機,此欄將指出開機程式名稱,稍後以 TFTP 傳送。
options
允許廠商定議選項(Vendor-Specific Area),以提供更多的設定資訊(如:Netmask、Gateway、DNS、等等)。其長度可變,同時可攜帶多個選項,每一選項之第一個 byte 為資訊代碼,其後一個 byte 為該項資料長度,最後為項目內容。
CODELENVALUE
此欄位完全兼容 BOOTP ,同時擴充了更多選項。其中,DHCP 封包可利用編碼為 0x53 之選項來設定封包類別:
項值類別
1DHCPDISCOVER
2DHCPOFFER
3DHCPREQUEST
4DHCPDECLINE
5DHCPACK
6DHCPNACK
7DHCPRELEASE
DHCP 的選項非常多,有空請查閱 RFC 或相關文獻,並好好理解,這裡不再敘述了。

DHCP 協定之 RFC 文件
RFC-951﹑RFC-1084﹑RFC-1123﹑RFC-1533﹑RFC-1534﹑RFC-1497﹑RFC-1541

習題﹕


  1. 請問 DHCP 的前身是甚麼?還有,DHCP 是做甚麼用的?
  2. 請列舉 DHCP 的分配形式,並加以說明。
  3. 請詳述 DHCP 的發放流程,並留意不同階段所用的封包類型。
  4. 請用圖畫出 DHCP 的簡單發放流程。
  5. 請問跨網路的 DHCP 是如何運作的?
  6. 請繪 DHCP 的封包結構,並嘗試簡述每一欄位的意思。
  7. 請說明編碼為 0x53 至 DHCP Options 有哪些值,及其代表含意。

星期五, 3月 26, 2010

威士忌


帶著葡萄氣味的威士忌 帶著芬芳果香的威士忌 帶著煙燻潮土的威士忌,每一瓶經數年熟成蒸餾的玉液瓊漿,因產地的氣候與風土民情為他們帶來獨特的風味。


一口Johnnie Walker,代表一段歷史,一個產地,是本金色軟香的教科書,得靠五官而閱覽的經典。


這是第三段~~。



星期一, 3月 22, 2010

失落

上個禮拜五參加了三中學弟的烤肉趴,地點是在大佳河濱公園。碰到了好多許久不見的朋友。而這次來的退伍的人,我已經是第二老的了。在場還在當兵的,大半都是我第一次見面。

那天我很HIGH,甚至覺得是裡面最HIGH的一個,覺得跟這些舊雨新知在一起,特別自在,我笑他們也笑,我叫他們也叫,就好像在潘朵拉星球上的族人一樣~~有種生命共同的感覺。

我終究是個群居動物,無法忍受孤單。

星期五, 3月 19, 2010

關於JN5139

(2010.4.20)最近查了資料,發現5139是有提供燒寫的函式,誤會一場,哈哈。

星期二, 3月 09, 2010

[轉貼維基]Electronic Shelf Label


Electronic Shelf Label
also known by the acronym ESL, is a system used by retailers for displaying product pricing on shelves. Typically, electronic display modules are attached to the front edge of retail shelving. These modules use Liquid Crystal Display (LCD) or similar technology to show the current product price to the customer. A communication network allows the price display to be automatically updated whenever a product price is changed. This automated system reduces pricing management labor costs and improves pricing accuracy.

上頭提到ESL是一個使用在零售商的一個可以顯示售價的系統。所以上頭會有個顯示模組,可能是LCD或者其他的顯示器。透過網路可以隨時變更並顯示售價。

星期一, 3月 08, 2010

[轉貼]如何解決Windows XP沒有「安全性」標籤

在開發WEB Project的時候,常常需要去設定一些安全性權限,但是有些人的XP就是找不到這個標籤。要怎麼解決這個問題?

有兩種方法:

第一種:

1. 在[我的電腦]中,選擇[工具]->[資料夾選項]

2. 在[檢視]中,將[使用建議檔案共用 (建議使用)]取消勾選。

setting

3. 然後你的安全性標籤就會顯示出來了.

第二種:

1. 在[開始]->執行->輸入regedit

2. 找到下列機碼(如果沒有找到,請自行新增),然後將值改為0。

Hive: HKEY_CURRENT_USER
Key: Software\Microsoft\windows\CurrentVersion\Policies\Explorer
Name: Nosecuritytab
Type: REG_DWORD
Value: 1

P.S. 安全性標籤僅能在Administrator權限下使用, 且檔案系統需為NTFS.



另依篇文章提到關於這則的設定:


http://blog.xuite.net/jeanson61/xuite/12574494

星期四, 3月 04, 2010

[軟貼軟體設計必讀經典(11)反覆測試與修正,讓錯誤消失

http://www.ithome.com.tw/itadm/article.php?c=47536

寫程式之路還有很多事情需要去學習,每每寫到一個程度的時候,都會想說,有沒有更好的寫法,或是更好的規劃方式。就是這種富有彈性的工作,所以才不會變得枯燥。

不過在這個競爭的行業裏面,效率往往決定一切,我仍然會害怕悠悠哉哉的寫程式,老闆會生氣~~。

測試驅動開發除了讓軟體人員對測試工具有自我主宰的感覺,並藉此探索測試內部的機制外,還能提升勇氣──取代沈默寡言,而勇於嘗試更多的溝通交流。

  Test Driven Development By Example
 Kent Beck /著
 Addison-Wesley Professional出版
 售價:44.99美元
 推薦:Amazon四顆星

有一位軟體設計的夥伴,是我看過上千軟體人員之中唯一的天才。他不只學習能力快速,更具備靈活的頭腦與身段,抽象思考能力極高,擅長把軟體作「軟」的他,作品總是令人嘆為觀止。不過,我覺得他與國外的軟體先驅仍差了一截,並不是實作或學習能力不夠好,最主要的差距在於「創新能力」。

什麼是創新能力?舉個例子,我可以看得出早期EJB規格的問題點(軟體結構會被該規格綁死死的),所以會批判與避免使用它。Rod Johnson 卻不只是批判反對而已,而且還身體力行,寫出Spring Framework,實現IoC(Inversion of Control)、AOP(Aspect-Oriented Programming)的輕量級開發框架,釐清軟體開發人員與系統層級服務的責任。

另外,《Test Driven Development By Examples》作者Kent Beck在輔導專案的過程,有感於測試應伴隨所開發的程式碼,而不是延遲,所以主張「測試先行」(Test First),他甚至設計免費開放的JUnit Framework等測試框架,並寫書推廣正確觀念,讓開發者了解測試先行是維繫軟體品質的重要關鍵。太多大型單位把測試當作一個重要製程,但又交給其他部門,而且在開發後才展開測試,這樣的應變測試效果令人懷疑。

先測試,再反覆修正到正確為止
全書分成三大部分,前兩大部分是範例,第三部分則是測試驅動開發(Test Driven Development,TDD)的設計模式(Patterns)。
第一部分以一個「幣值轉換」的程式範例,利用Java程式碼揭露TDD的設計意涵。

看到這個範例,你可能會覺得程式碼的寫法實在不高明。是的, Kent Beck盡量模仿初學者的程度撰寫程式碼,這同時說明TDD簡單明瞭,能讓初學者快速上手,並懂得如何修正程式碼 (這其實已經逐漸走向設計之道了)。這部分內容讓你了解什麼才是Test First──還沒寫類別程式碼之前先寫測試程式碼。當然,測試一定不會過,再來才開始寫主題程式,新增類別、編輯屬性、修改參數……等。簡單的設計、列出工作清單、一次只解決一個問題、測試它、讓它正確……如此地反覆修正,這正是TDD最重要的精神。

第二部分藉由Python語法探索xUnit測試框架的設計過程,教你如何撰寫屬於自己的測試框架。你也許認為開發Framework相當困難,但Kent beck的作法是如此簡單,三兩下就可以開發出測試框架,而且在設計的過程中,還能秉持測試先行的原則。作者使用Python作為範例,原因除了語法易懂之外,因為Python屬於Script-Based語言,也能藉此證明Python能實現測試框架的實作。

不過,目前已有30多種程式語言支援xUnit Framework,為何作者還要鼓勵程式人員開發屬於自己的測試框架?

有兩個理由:一、讓你對測試工具有自我主宰的感覺;二、藉此探索測試內部的機制。

第三部分是TDD的設計模式,這部分談到測試的策略思考,包括測試的意涵、什麼時候要測試、應該選擇什麼樣的邏輯與資料作測試。

簡單就是力量
TDD的核心精髓是:讓程式碼可以運行並能保持純潔無瑕(Clean code that works)。另外還有兩項原則:一、只有自動化測試失敗時,才寫新的程式碼;二、消除重複(Duplication)。其中,消除重複又與系統架構的相依性(Dependency)設計有相當密切的關係,消除重複的程式碼後,系統的耦合(Coupling)程度往往能夠降低,進而提升可再利用性的價值。

Kent Beck 還特別在序文提到「勇氣」(Courage)。他認為測試驅動可以在開發過程中控制開發者的憂慮感,它可以讓你:快速具體地學習,而不是一直處於試驗性的階段;取代沈默寡言,而有更多的溝通交流;不是躲開回報,而是更能尋求具體有幫助的回饋(Feedback)。

當閱讀完本書後,我相信你應該就能掌握TDD的開發精神,能落實:(1)從簡單開始做起;(2)寫自動化的測試程式;(3)重構 (Refactor),而且每次只增加一個新的設計。

《作者簡介》王克明
台北工專五專部電子科畢業。現於HSDc軟體設計顧問團隊擔任架構師/顧問/講師。興趣為整體架構性的思考與學習、期貨投機操作與閱讀。

星期五, 2月 12, 2010

[轉]#ifdef _DEBUG

以前看過,不過這種東西一陣子沒看又忘掉了,所以還是把他存起來。

連結http://huenlil.pixnet.net/blog/post/24339151

接下來則是在知識+看到的,一些小問題知識家還是有不錯的答案可以參考。
連結

#ifndef _STDLIB_H_
#define _STDLIB_H_
... some code
....

#endif // of _STDLIB_H_

這樣的用法一般會寫在header file 當中.
目的是為了避免重覆include 同一個header file compiler 會發出重覆宣告的錯誤

用法如下
#ifndef _STDLIB_H_ // 如果沒有定義_STDLIB_H_ 這個macro 則下面的code 會被展開直到 #endif
#define _STDLIB_H_ // 定義 _STDLIB_H_


#endif // 結束 前制處理器的if 判斷 區段


所以當user 第一次include 時. _STDLIB_H_ 還沒被定義過. 此時#ifndef 到 #endif 的code 會被展開. 又此段當中有一個#define _STDLIB_H_ . compiler 就會記住_STDLIB_H_ 被定義過
當第二次在include 同一個檔案. compiler 發現 _STDLIB_H_ 被定意過了. 此時#ifndef 到 #endif 之間的code 就不會被展開了.
達到防止重覆include 的效果


example program 共3 個檔案
-----------------------------------------
file : abc.h
#ifndef _ABC_H_
#define _ABC_H_

const int a=100;

#endif // of _ABC_H_

-----------------------------
file : 123.h
#include "abc.h"


-----------------------------
file : main.cpp
#include "123.h"
#include "abc.h"

int main()
{
return 0;
}

把上面三個檔分別存成abc.h 123.h 跟main.cpp
compiler main.cpp 妳會發現不會有錯誤發生.
但是如果把abc.h 去除#ifndef _ABC_H_ 等等 如下面
file : abc.h
// 沒有#ifndef _ABC_H_ 的abc.h

// #ifndef _ABC_H_ <== mark 掉
// #define _ABC_H_ <== mark 掉

const int a=100;

// #endif <== mark 掉

再次compiler main.cpp
妳會發現compiler 會跟妳說 a 重覆宣告
VC 的error 如下
f:\temp\abc.h(7) : error C2370: 'a' : redefinition; different storage class
f:\temp\abc.h(7) : see declaration of 'a'

星期日, 1月 17, 2010

How to use DEV C++ Debug

我不得不說當我一開始用Dev學習C++的時候,並不會使用debug的功能,完全是靠cin與cout來看看程式有沒友執行錯誤,後來使用TI的CCS才發覺breakpoint與watch window是我debug必用的工具。

現在回來使用DEV的時候,才發現我不會用它的debug,看了它的Help只看到了一個"ID DEBUG PROCESS"關鍵字,卻不知道要怎麼使用,想說DEV已經是很GUI的設計,Debug會做得那麼難使用嗎~~。

還好我隨手google一下,發現我錯了,其實他還是蠻容易的,不過我的步驟錯了。

以下是Dev C++的一種Debug的步驟:
原始網頁:

1.code先編譯(Ctrl+F9)
2.再設中斷點
3.debug(F8)

原本點選的中斷點那行底色變成藍色代表程式跑到該行,此時也可以使用watch window。



星期一, 1月 04, 2010

在DEV C++上開發GTK+

我想這篇是我怕下一次忘了怎麼用,人啊,還是做一下紀錄比較好。

今天試了將近整整一天,發現怎麼樣安裝,DEV總是出現很多錯誤,明明CODE都是未修改過的Sample Code。

最後,我找到這篇文章:

我照著做到最後,還是有錯誤發生,後來我想到會不會是牽涉到中文檔名與碰到中文路徑的問題,所以我把專案的名稱改成英文,並存在D槽底下,沒想到就這樣給他成功了。
不過目前發現程式上按鈕的字都是顯示亂碼,看起來還有得學~~。

星期六, 5月 02, 2009

消失的瓢蟲

約莫20年前,九星瓢蟲是隨處可見的。現在,它與其它隨處可見的品種變得稀有。你可以與科學家們探索原因。拍下瓢蟲的照片並傳到瓢蟲消失專案(Lost Ladybug Project)。

沒有人知道為何瓢蟲會消失。"也許是氣候改變的緣故 引進外來種或是其他的因素"專案主持人John Losey回答TFK。

蟲蟲的生活
專案從2004年收集了1000張照片,它們將被用來建構資料庫以便追蹤不同品種蟲蟲的生態。瓢蟲有5000種品種,而在美國本土品種則有450種。

小蟲蟲有很大的使命。它保持花園及農田pestfree(譯註:我找不到翻譯~~)。但在某些地區,外來種主掌大權,"超過一半以上的圖片是來自亞洲的品種"Losey表示。

斑點
瓢蟲消失專案越來越難蒐集到瓢蟲的圖片比起20年前,即使你找到一般的瓢蟲,把你的照片上傳吧。"每一之瓢蟲都很重要"Losey說。

星期六, 10月 04, 2008

免費植物-第一週

其實是參加一個回收活動送的。

凡事只要20顆電池OR20片光碟就可以兌換一顆植物。結果我拿回來的這顆植物,我還真不知道它叫啥名字。詢問了一下朋友,它應該是菊科的植物。

這是第一週,希望它可以延續到第二週 第三週~~。

愛買的回收活動送的,不知名稱@@
所以拍下葉子,應該可以找到一些蛛絲馬跡

剛換回來,看起來還蠻精神飽滿的,高約9.5公分。

星期四, 9月 25, 2008

星期五, 9月 19, 2008

日記

昨天去LEO哥家做地球,席間還有騎士 小孟 桃花公子XD 阿達。

第二次去LEO哥家,就更習慣一些了,LEO哥的女紅不俗,做起事來一板一眼,我對他地巧手敬佩不已。

小孟見到了我,就跟我聊了許多的事情,久違不見的熱絡感,我在新竹已經很久沒遇見了QQ。

桃花公子過了11點之後,就只剩下軀殼與我們同在,不過在隔天,我們小聊了一下,希望你大五的課全部ALL PASS。

如果說LEO哥是使用裁縫機的高手,那麼騎士則是能駕馭電鑽的達人,所以的木工DIY都由他一手搞定~~。

這次跟大家依據,還蠻開心的喲^^

星期日, 9月 14, 2008

日記

這兩三天我待在 楓葉紅/阿強 家裡,就在辛樂克(跟星巴克跟有啥關係(誤))來台玩的這幾天。

阿強他請我吃竹東首屈一指的牛肉麵,牛肉湯香氣四溢,加上秋颱來臨的微寒氣候,這碗麵滿足了我的口體。

阿強有許多交心的好朋友,我也在這幾天一一的看到了,見到她跟朋友的相處的方式,大概知道為何他能夠贏得那些朋友的信任,一切的根本來自於單純與誠懇啊。跟我的假單純及偽誠懇不同XD。相信我,你很快就能交到許多圈內的知心朋友的^^

隔天ㄚ強帶我認識他的姊姊,阿強姊幾乎擔任阿強左腦的角色,理性地為他分析所有他遇到的世態,每個人的身邊有這樣的家人,是件幸福的事情不是嗎~~。不管你未來的伴侶是男是女,能夠永遠永遠愛你的,就是你的家人,你有一個很棒的姊姊。

禮拜六的早上,只剩下我跟阿強在房間,阿強問了我一些感情的問題,每次別人問我問題的時候,就是我省視自己的時候。希望我的答案不會讓你更加迷惘,其實說不定,你已經知道答案了,但往往就是會掉進逃不開的循環裡,有些事情經歷兩次三次,就該下個決定了,玩遊戲也是會遇到升等升級的時後,趕快解決掉小囉囉,以後就要迎戰大魔王XD。

颱風的不平靜,那心呢。

星期二, 9月 09, 2008

日記

宗易之不專業之不負責任之因為沒有VIP所以請自行點擊網址到YOUTUBE之音樂教室


最近我最喜歡的天生歌姬小克(Christina Aguilera)要出精選輯了(迷:據說是只有12首歌左右的凍酸精選集QQ),我就把她以前的歌再一一拿出來聽,小克可以說是我聽過聲音最為厚實的女歌手啊(茶)。

小克詮釋過許多歌曲,其中最為一般外人熟之可能就是這首
Lady Marmalade
(但我更喜歡這個版本)

這首老歌新唱為電影紅磨坊(Moulin Rouge)的主題曲,且在當時登上排行榜好幾週冠軍。

除了這首歌之外,其實紅磨坊也帶起了歌舞片搬上大螢幕的風潮,就像七夜怪談帶起了鬼片風潮一樣,往後推出同類型的片子時,都會打上"票房更勝XXX"來吸引喜歡這類型片子的戲迷。

既然是部以歌舞為重點的電影,紅磨坊的音樂便是全劇靈魂所在,裡面除了剛剛介紹的Lady Marmalade外,原聲帶還包含拉丁音樂 印度風的舞曲 將艾爾頓強的UR Song重新詮釋,也再度讓這首歌翻紅,這是張我少見整張都會很HIGH的電影原聲帶。

而事隔多年,這張專輯我又再度拿下來聆聽,發現裡面我比較少注意到的一首法文歌,整首歌只用簡單的伴奏襯托,在電影中作為男主角回憶當初隻身來到巴黎的背景音樂,就是這首
Complainte de la Butte
演唱者帶著濃濃的憂愁的情緒,讓人彷彿也掉進了那段少不經事的黑白記憶。
而我細看這個演唱者時,發現他的名字有些眼熟,以及他那種靈魂味很重的聲音,我想起這幾年的另一個作品,也是我最鍾愛的一首歌。
King of the Road
Jack帶著愉悅的心情與Ennis見面,在車上哼起這首意氣風發的歌,但沒想到Ennis卻做了一個令他心碎的決定~~。

爾後來一比對,其一果真是同一個演唱者:Rufus Wainwright

在兩三年前吧,我在看完斷背山之前,就買了這張原聲帶,其中看了介紹便知道他是位已出櫃的創作歌手,所以開始專心聽他所詮釋的歌曲,就很喜歡他聲音那種哀愁的特質。

同一張CD有他的另外一首歌,他唱出了心碎的感覺。

The Maker Makes

沒想到在我擁有的兩張好像沒有交集的CD找到了共通之處,讓我又再一次注意到這個歌手,我把他介紹給你^^

星期四, 9月 04, 2008

日記

我喜歡上了一個人,一個第一次我想要主動追求的人。

不過對方已經有男朋友了,我想他B以及他的決定是對的,像我這樣的人應該要被隔離。


大部分的"這個"星座,都會盡量做好人,主要是害怕被當成壞人,惹來不必要的麻煩。少數被稱為好人還傻笑得出來的人種。

他們的MSN上,出現最多的就是^^

應付這種星座,是可以假裝為他們好的。因為當他們一發現對方在背後作了有違朋友的事情時,他會不敢相信好久,對方就可以趁機想到好的理由或是繼續假裝沒事稱兄道弟。他們就會當做夢似地忘了。

星期三, 9月 03, 2008

日記

15:00

我要去湖口老街了。

我這兩年認識了很多朋友,在臨別的時候我都會說,有空來新竹找我,我帶你去逛逛。

但是整理我手頭上的一些地點,其實還有一部分我沒有去過ORZ,所以趁著這幾天,我想走過那些所謂的熱門景點,好帶朋友去走走。

而如果走出新竹市,離我最近的景點就是湖口(竹北我還不熟XD),今天就憑著手畫的地圖,騎上摩托車就出發了。

繞了一些冤枉路,但一切都算順利,沒有發生騎車到高速公路的意外XD

我喜歡一個人冒險,並非說不喜歡跟人們去旅行。當我跟別人去旅行,我會將大部分的決定權交給其他人,為得是求得一種安穩,不想在玩的時候操煩東操煩西的,我喜歡跟會規劃的人一起行動,不論他規劃得好不好。

所以我稱為一個人的旅行叫做冒險,因為我的個性導致每一步都走得戰戰兢兢,不過又刺激,一種一般人覺得是大驚小怪的刺激XD

湖口老街老實說不長,但夾雜在現代的公路以及住宅間,刻意保留著客家的傳統精神,旁邊還開了一條自行車道,我看地圖上的路程不短,卻好像還未規畫完,走到一半路就斷了,那段路程風景還算"有趣",有樹以及河流XD

我已經把湖口老街納入我帶朋友來的景點之一~~。

星期二, 8月 26, 2008

日記

什麼是忌妒,我是沒有資格去這麼做的。但我好想,忌妒也是一種情緒的宣洩吧。

另一個我不會讓我這麼做的。

你說的對,也許我真的是無聊沒事做吧,才會東想西想。



當我們互相擁抱的時候,我的心裡得到了某種程度的救贖,謝謝你,我正需要這個。

星期六, 8月 23, 2008

日記

今天差了3~五分鐘沒趕上火車,結果遲了很久才跟隊伍會合。

我在那台已經沒有位子的車上,擁擠而搖晃地等待下車的時間,信手翻讀隨身攜帶的書,有一篇文章談到"定"。

所謂"定 靜 安 慮 得",心中要有所安定平穩,才會有所得。所以我在車上開始平心靜氣地欣賞車窗外的風景,聽一聽鐵軌"喀啦 喀啦"的對話。這就是我喜歡閱讀的地方,能依照當時的情況,讀到對自己有幫助的字句。

結果就遇到了文董他們,還有一個新朋友 楓葉紅/阿強 ,楓葉紅是個讓我印象深刻的人,包含他突然湊過來,用一種"我知道你也是"的神情跟我說:我是楓葉紅,我覺得很可愛,而且楓葉紅是個很健談的人,所以剩餘的三十幾分鐘車程很快就過去了。

楓葉紅持續讓我印象深刻,就在我們走錯路之後發生的意外,那時的我真的手足無措,還好友文董跟他學弟兩個軍人,而楓葉紅的臨機應變夠快,所以看起來沒有什麼大礙。下次不要再這樣嚇我了QQ


接下來我們騎了腳踏車 去海邊 晚上去吃很特別的印度珈哩餐 最後跑去方,不過我腦中都還心繫楓葉紅那,想說如果他沒受傷就可以來參加了,畢竟我們是同鄉^^